#22 new

Manage Navigation Naming Convention Change

Reported by expNinja | March 10th, 2011 @ 06:11 AM | in Beta 1

I'd like to put a request in to chage exponent terminology from "Manage Navigation" to "Manage Pages" ... It's easier for non-techies and we're managing all pages and not just the main navigation. Most users don't even know what "Navigation" means.

Comments and changes to this ticket

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Bug Tracker for Exponent CMS

Shared Ticket Bins

People watching this ticket