#1420 new
dleffler

Feature request: Remove PHP v5.3, v5.4, & v5.5 support

Reported by dleffler | September 12th, 2017 @ 03:41 PM | in 2.5.0

Since the oldest supported/recommended version of PHP is v5.6 at this time (v7.1 is current, with v7.2 out soon), we should require (encourage) administrators to push for server upgrades. A side-effect will be easier coding (no need to support so many minor versions of PHP)

Comments and changes to this ticket

  • dleffler

    dleffler September 12th, 2017 @ 09:24 PM

    As a note, v 5.5 support ended over a year ago though it's still listed as 'old stable' on the php.net site. v5.4 lost support two years ago, and v5.3 lost support 3 years ago. v5.6 and v7.0 will lose security updates/support in Dec 2018.

  • dleffler

    dleffler September 13th, 2017 @ 07:56 PM

    A recent push prior to the release of v2.4.2 requires at least php v5.5 to run/upgrade Exponent. This will at least ensure that all the 3rd party libraries work (many no longer support v5.3)

  • dleffler

    dleffler December 23rd, 2017 @ 04:13 PM

    • Assigned user set to “dleffler”

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Bug Tracker for Exponent CMS

Shared Ticket Bins

People watching this ticket

Tags

Pages